
运维服务
docker离线安装
一、准备工作:确认架构并下载安装包 1.1 确认目标服务器架构 在目标服务器上执行以下命令,确认系统架构: 输出 x8664:对应 amd64 架构(Intel/AMD 64位服务
[root@www.wulaoer.org ~]# umount /apps/
umount: /apps: target is busy.
(In some cases useful info about processes that use
the device is found by lsof(8) or fuser(1))
先找出挂载目录中在运行的程序,然后在kill掉,下面使用lsof查找挂载目录中运行的程序。
[root@www.wulaoer.org ~]# lsof | grep /apps/ ................................ [root@www.wulaoer.org ~]# kill 1234kill后在umount会卸载掉,但是在格式化的时候,还是不行,这是因为挂载的时候使用的是逻辑分区,需要把逻辑分区remove_all后才可以对硬盘进行分区
[root@www.wulaoer.org ~]# dmsetup status vg_data-lv_data: 0 83886080 linear逻辑分区的状态,这个不能直接使用,需要remove_all后才可以
[root@www.wulaoer.org ~]# dmsetup remove_all [root@www.wulaoer.org ~]#remove_all后你在使用dmsetup status你会发现格式就正常了。 注意,一定要把fstab文件中挂载的信息修改掉,如果不修改就会导致系统重启的过程中检测不到原来的盘,导致系统启动失败,需要进入root修改fstab文件才能把系统启动起来。
评论 0