
DevOps
Jenkins 构建 Node 项目内存溢出(JavaScript heap out of memory)解决方案
1\. 问题描述 在 Jenkins CI/CD 构建前端项目(Vue / Vite / Webpack 等)时,执行: 报错: 即 Node.js 在运行时超出了默认 V8 引擎
[root@wulaoer ~]# wget -O /etc/yum.repos.d/jenkins.repo https://pkg.jenkins.io/redhat-stable/jenkins.repo [root@wulaoer ~]# rpm --import https://pkg.jenkins.io/redhat-stable/jenkins.io.key [root@wulaoer ~]# yum install jenkins
[root@wulaoer ~]# wget https://pkg.jenkins.io/redhat/jenkins-2.156-1.1.noarch.rpm [root@wulaoer ~]# rpm -ivh jenkins-2.156-1.1.noarch.rpm安装比较好安装,主要是配置,这里注意安装之前必须安装java,因为jenkins依赖java,如果不安装java,jenkins就会启动失败。如果你要打包的项目是java项目,需要注意的是java的版本必须和项目的版本一致,防止打包的过程中出现问题。
[root@wulaoer ~]# egrep -v "^#|^$" /etc/sysconfig/jenkins JENKINS_HOME="/var/lib/jenkins" #jenkins的路径 JENKINS_JAVA_CMD="" #java的路径 JENKINS_USER="jenkins" #打包以jenkins用户打包 JENKINS_JAVA_OPTIONS="-Djava.awt.headless=true" #打包 JENKINS_PORT="8080" #端口 JENKINS_LISTEN_ADDRESS="" JENKINS_HTTPS_PORT="" JENKINS_HTTPS_KEYSTORE="" JENKINS_HTTPS_KEYSTORE_PASSWORD="" JENKINS_HTTPS_LISTEN_ADDRESS="" JENKINS_HTTP2_PORT="" JENKINS_HTTP2_LISTEN_ADDRESS="" JENKINS_DEBUG_LEVEL="5" JENKINS_ENABLE_ACCESS_LOG="no" JENKINS_HANDLER_MAX="100" JENKINS_HANDLER_IDLE="20" JENKINS_EXTRA_LIB_FOLDER="" JENKINS_ARGS=""根据自己的环境配置成功后,启动jenkins,进行页面配置
[root@wulaoer ~]# systemctl start jenkins利用ip加端口的方式请求,如果你想做域名解析可以考虑nginx的反向代理,参考:https://www.wulaoer.org/?p=620,我这里使用ip加端口,http://10.211.55.5:8080/
提示需要输入密钥,并贴进去
[root@wulaoer ~]# cat /var/lib/jenkins/secrets/initialAdminPassword e0f962e7c6764b5798fc20cd5efb91c6贴进去后,右下角继续。
根据自己的需求,选择不同的安装方式,我选择的是推荐安装,推荐安装和选择安装插件都差不多。
如果出现失败继续重试即可,安装完成,需要设置一下管理员的密码。
设置一下用户名和密码保持即可,下一步
这里如果不加nginx做代理可以使用ip加端口的方式。
安装成功,下面就是如何使用Jenkins了
评论 0