👋 欢迎来到吴老二技术博客,专注运维 / 数据库 / 云原生
首页/数据库/正文

mysql启动报错找不到pid文件

吴
吴老二
2019-12-13数据库2898 次浏览0 条评论
我的mysql总是在重启的时候mysql的数据总是会初始化,我以为是的配置问题,所以在网上找了各种方法测试都不通过,下面看我遇到的几个错误。

重启mysql失败

[root@wulaoer_mysql mysql]# /etc/init.d/mysql restart
 ERROR! MySQL server PID file could not be found!
Starting MySQL... ERROR! The server quit without updating PID file (/usr/local/mysql/var/wulaoer_mysql.pid).
mysql正常重启的时候突然出现找不到pid文件,解决方法:
[root@wulaoer_mysql mysql]# ps -ef | grep mysql
root     12676     1  0 Dec11 pts/1    00:00:00 /bin/sh /usr/local/mysql/bin/mysqld_safe --datadir=/usr/local/mysql/var --pid-file=/usr/local/mysql/var/wulaoer_mysql.pid
mysql    13193 12676  0 Dec11 pts/1    00:02:58 /usr/local/mysql/bin/mysqld --basedir=/usr/local/mysql --datadir=/usr/local/mysql/var --plugin-dir=/usr/local/mysql/lib/plugin --user=mysql --log-error=wulaoer_mysql.err --open-files-limit=65535 --pid-file=/usr/local/mysql/var/wulaoer_mysql.pid --socket=/tmp/mysql.sock --port=3306
root     17416 16793  0 18:33 pts/3    00:00:00 grep --color=auto mysql
有死进程存在,把进程kill掉,重启正常。

重启后设置的密码失效

我的是5.6版本的mysql,使用这个命令修改密码,重启之后密码没有修改,而且配置文件中没有跳过密码验证。
update user set authentication_string=password('root') where user='root';
使用这个语句修改成功
update user set password=password("root") where user="root";

mysql启动报错The server quit without updating

mysql启动的时候报错信息:
[root@wulaoer_mysql var]# /etc/init.d/mysql start
Starting MySQL. ERROR! The server quit without updating PID file (/usr/local/mysql/var/wulaoer_mysql.pid).
解决方法删除binlog文件以及ibdata1文件,这个只删除ibdata1、ib_logfile1、ib_logfile101应该就可以解决的,
[root@wulaoer_mysql var]# pwd
/usr/local/mysql/var
[root@wulaoer_mysql var]# ll
total 20628
-rw-rw----. 1 mysql mysql 10485760 Dec 13 18:44 ibdata1
-rw-rw----. 1 mysql mysql  5242880 Dec 13 16:07 ib_logfile1
-rw-rw----. 1 mysql mysql  5242880 Dec 13 18:44 ib_logfile101
drwx------. 2 mysql mysql     8192 Dec  9 17:14 jumpserver
drwx------. 2 mysql mysql     4096 Dec  7 17:51 mysql
-rw-rw----. 1 mysql mysql        0 Dec 13 18:44 mysql-bin.index
drwx------. 2 mysql mysql     4096 Dec  7 17:51 performance_schema
-rw-rw----. 1 mysql mysql    96763 Dec 13 18:47 wulaoer_mysql.err
[root@wulaoer_mysql var]# rm -rf ibdata1 ib_logfile1 ib_logfile101
[root@wulaoer_mysql var]# ll
total 148
drwx------. 2 mysql mysql   8192 Dec  9 17:14 jumpserver
drwx------. 2 mysql mysql   4096 Dec  7 17:51 mysql
-rw-rw----. 1 mysql mysql      0 Dec 13 18:44 mysql-bin.index
drwx------. 2 mysql mysql   4096 Dec  7 17:51 performance_schema
-rw-rw----. 1 mysql mysql 101282 Dec 13 18:47 wulaoer_mysql.err
[root@wulaoer_mysql var]# /etc/init.d/mysql start
Starting MySQL.. SUCCESS! 
以上是针对mysql5.6版本的问题解决方式,其他版本的没有使用,后期使用在更新。  
文章底部广告位在后台「广告设置」填写广告代码后显示

评论 0

评论需 登录 后发表(注册并验证邮箱)。
还没有评论,来抢沙发~