👋 欢迎来到吴老二技术博客,专注运维 / 数据库 / 云原生
首页/运维服务/正文

nginx报错XSRF check failed

吴
吴老二
2021-04-14运维服务4122 次浏览0 条评论
今天在打开以前搭建的wiki的时候,出现错误XSRF check failed,以前使用的时候没有问题,我这里的结构是利用nginx做反向代理,跳转到wiki服务上,出现这个错误的时候第一反应就是我的nginx出现的问题,因为以前没有修改过,而且可以使用,所以是不是以前就应该出现这个错误,这个错误的原因是跨域的问题。以前之所以没有出现可能使用的不频繁,今天才出现这个错误是因为我需要编辑,才会有的,刚刚复现了一下没有复现过来,所以就不截图了
server
    {
        listen 443 ssl;
        server_name ops-wiki.wulaoer.org;
        ssl_certificate /usr/local/nginx/ssl/4923506__wulaoer.org.pem;
        ssl_certificate_key /usr/local/nginx/ssl/4923506__wulaoer.org.key;
        ssl_session_cache shared:SSL:1m;
        ssl_session_timeout 5m;
        ssl_ciphers  HIGH:!aNULL:!MD5;
        ssl_prefer_server_ciphers  on;
        index index.html index.htm index.php;
        include enable-php.conf;
        location / {
            proxy_pass http://10.16.208.133:8090;
            proxy_redirect off;
            proxy_set_header Host $host;
            proxy_set_header  X-Real-IP  $remote_addr;
            proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
            client_max_body_size 50m;
            client_body_buffer_size 256k;
            proxy_connect_timeout 30;
            proxy_send_timeout 30;
            proxy_read_timeout 60;
            proxy_buffer_size 16k;
            proxy_buffers 4 32k;
            proxy_busy_buffers_size 64k;
            proxy_temp_file_write_size 64k;
        }
        access_log  /home/wwwlogs/ops-wiki.wulaoer.log;
    }
调整后的配置就是增加了proxy_set_header X-Forwarded-Proto $scheme;,正常应该是四行proxy_set_header,因为我原本是有三行所以加了一行。
server
    {
        listen 80;
        listen 443 ssl;
        server_name ops-wiki.wulaoer.org;
        ssl_certificate /usr/local/nginx/ssl/4923506__wulaoer.org.pem;
        ssl_certificate_key /usr/local/nginx/ssl/4923506__wulaoer.org.key;
        ssl_session_cache shared:SSL:1m;
        ssl_session_timeout 5m;
        ssl_ciphers  HIGH:!aNULL:!MD5;
        ssl_prefer_server_ciphers  on;
        index index.html index.htm index.php;
        include enable-php.conf;
        location / {
            proxy_pass http://10.16.208.133:8090;
            proxy_set_header Host $host;
            proxy_set_header  X-Real-IP  $remote_addr;
            proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_set_header X-Forwarded-Proto $scheme;   #增加了这个
            client_max_body_size 50m;
            client_body_buffer_size 256k;
            proxy_connect_timeout 30;
            proxy_send_timeout 30;
            proxy_read_timeout 60;
            proxy_buffer_size 16k;
            proxy_buffers 4 32k;
            proxy_busy_buffers_size 64k;
            proxy_temp_file_write_size 64k;
        }
        access_log  /home/wwwlogs/ops-wiki.wulaoer.log;
    }
修改后,重新加载一下或者重启一下nginx即可,我的问题是不能编辑wiki,重启后就可以编辑wiki内容了。问题解决了。。。。。。
文章底部广告位在后台「广告设置」填写广告代码后显示

评论 0

评论需 登录 后发表(注册并验证邮箱)。
还没有评论,来抢沙发~