
prometheus重启探针报错opening storage failed: lock DB directory: resource temporarily unavailable
prometheus修改配置文件后需要重新加载,重启后prometheus的探针一直在重启,删除重新创建会导致数据丢失,所以还是需要解决这个问题,主要是因为prometheus运行
共 180 篇文章

prometheus修改配置文件后需要重新加载,重启后prometheus的探针一直在重启,删除重新创建会导致数据丢失,所以还是需要解决这个问题,主要是因为prometheus运行

部署的prometheus在target中显示server retumed HTTP status 403 Forbidden,插件什么的都已经安装好了,正常不应该有这个错误,同一

ingress是kubenetes中的nginx,所以nginx中可以配置的功能,在ingress中同样可以配置,下面看一下如果配置ingress的配置。在ingress中配置的文

为了方便用户可以随时查看监控信息,需要在grafana中配置免密码登录,免密码登录的用户又不能随时修改配置信息,所以grafana自身提供了一项免密码登录的功能,根据自己的配置修改

遇到这种情景,平时的业务量不是很高,但是有时候做活动,流量是突然之间上升,由于伸缩是根据CPU和内存的阀值做的,但是瞬间的流量上升,导致容器启动后无法支撑大的流量处理,所以需要在流

kubectl是kubenetes的命令管理工具,通过kubectl来管理kubenetes,利用kubectl可以对kubenetes进行操作,不管是删除namespace,还是

新创建了一个pod,镜像使用的是别人制作的,可能在dockerfile里时间就没有设置,导致我启pod的时候,时间比当前时间慢了8个小时,如果我使用原来的镜像在写歌dockerfi

有时候遇到namespaces中的pod都已经删除了,在删除namespaces的时候总是停留在terminating的状态,使用kubectl delete namespaces

跨域主要是因为浏览器的同源策略限制,是服务对浏览器的一种约定,如果缺少,则对浏览器会产生影响,同源即是在同一个域中两个页面具有相同的协议,主要是protocol,主机host,端口

今天出现一个问题,我的golang两个同一个版本的镜像既然是共存的,不仅名称一样,镜像的Id也是一样的,我在做删除的操作时,既然只能删除一个,第二个怎么都删除不了,先看一下场景,在