
Kubernetes网络插件Flannel的3种工作模式
前言 跨主机通信的一个解决方案是Flannel,由CoreOS推出,支持3种实现:UDP、VXLAN、hostgwudp模式:使用设备flannel.0进行封包解包,不是内核原生支
共 180 篇文章

前言 跨主机通信的一个解决方案是Flannel,由CoreOS推出,支持3种实现:UDP、VXLAN、hostgwudp模式:使用设备flannel.0进行封包解包,不是内核原生支

k8s节点资源不足了,准备把部署一个新节点,安装docker的时候也没太在意,就直接安装了,加入集群的时候一直提示错误,但是错误是因为docker版本的问题,我安装的docker版

最近在做swarm环境,针对swarm的优点这里就不多说了,因为我们要部署到生产环境,资源比较少而且要求压力不是特别多,最主要的是避免浪费,选择了swarm,但是部署后,准备服务上

了解swarm的应该都知道swarm是kubernetes的早期版本,所以这里不在描述,在swarm中也是一样,在集群内部同一个网络中的服务通信是可以直接通过服务名称加端口的方式直

swarm的资源限制和kubernetes的资源限制一样,分别使用reserve和limit对容器资源进行限制,也可以理解为最大最小,而reserve可以理解为最小范围,初始资源大

docker安装好后,发现启动的时候报错,这里详细分析一下docker启动错误的方法。首先是启动docker,提示错误让你查看启动错误的日志,但是日志内容比较少,又没有详细的错误内

安装新版本docker的时候,发现启动不起来,因为以前使用这个镜像的时候直接启动了,也没有遇到过。也就谷歌了一下,发现是配置问题,因为以前没有遇到过,这里就记录一下, 虽然我是yu

我们一般在创建容器的时候,都是使用的普通用户进入容器,但是使用普通用户进入容器后就会出现有一些文件没有权限查看,很有就是安装等等很是麻烦,这里就说一下如何通过root用户进入容器,

利用nginx做反向代理kubesphere,目的是为了在自建环境中通过nginx反向代理到kuberetes中的ingress,然后利用ingress做集群内部的解析,利用ngi

ingress的主要目的是为了控制用户请求pod的一个入口,当然了,如果使用nodeport的方式更简单点,但是我需要给很多个服务设置端口,这种请求方式不太能接受,而且如果我使用n