👋 欢迎来到吴老二技术博客,专注运维 / 数据库 / 云原生
首页/运维服务

运维服务

共 195 篇文章

运维服务

nginx 转发websocket

要在 Nginx 中转发 WebSocket 连接,需要对其进行一些特殊的配置。以下是一个简单的示例: 在这个示例中,我们首先定义了一个名为 websocket 的 upstrea

2023-08-102201 次浏览0 条评论
运维服务

shell在远程机器上执行本地脚本

工作中遇到很多情况,必须一批新机器,需要在每个机器上执行一个命令,不过如果考虑ansible也是可以的,但是有些环境确实不太适合ansible,那么有没有什么方法是否可以不用ans

2023-04-301985 次浏览0 条评论
运维服务

Centos7安装的服务端口都在TCP6上了

今天在部署ELK的时候,服务都安装好了,准备进行验证的时候,发现验证不了。在本地通过ip+端口的方式也不能请求,也不提示错误,就是请求不了,后来看了一下端口,发现端口都在TCP6上

2023-04-142729 次浏览0 条评论
运维服务

利用nginx的反向代理替换成k8s的LoadBalancer

简单说一下k8s的负载均衡不管是LoadBalancer还是nodeport,还是其他的等等,都是通过端口映射的方式进行数据请求的,主要原因是因为在kubernetes中,ipvs

2023-03-142059 次浏览0 条评论
运维服务

centos7内核升级方法

今天在安装kubernetes的时候,什么都安装好了,但是在安装jenkins的时候提示一直安装不上去,后来发现原来pod中无法域名解析,主要原因是因为我的系统内核版本太低了,这里

2023-03-102156 次浏览0 条评论
运维服务

Centos7时区UTC修改成CST

系统时间不对就会对日志的收集造成没有必要的问题,也不利于异常问题的处理,这次就遇到了一次系统安装的时候没有选择时区,所以就记录一下,默认时区市UTC,和北京时间相差8个小时,这个看

2023-02-261717 次浏览0 条评论
运维服务

sshpass批量运行脚本

批量安装一些东西,可能很多人都会想到ansible,但是ansible属于配置比较复杂一点,这里说一下使用sshpass做批量处理,sshpass主要用来远程登录目标机器,但是目标

2023-02-182570 次浏览0 条评论
运维服务

git把本地删除的文件同步到远程仓库

拉取下的代码,自己有一个目录没有用了就想着删除,然后在同步到远程仓库中,但是发现怎么都同步不上去,使用git push的时候没有报错,但是就是没有同步,这里记录一下方法,看下面的代

2023-02-101910 次浏览0 条评论
运维服务

git上传的文件超过100M,如何删除后继续上传

今天在整理自己的文档时,就想着传到git上,以后编辑的时候来回方便,就不需要考虑文档不一致的问题了,然后把自己写的文档都传到git上,发现上传的时候有一个压缩文件一直上传不了,原来

2023-02-081992 次浏览0 条评论