
云原生
利用kurise做日志采集使用promtail做sidecar采集日志
利用OpenKurise中的kruise做日志采集,原来我使用的是filebeat作为sidecar采集日志的,虽然采集没有什么问题,但是通过es进才看日志就比较繁琐了,这次实验p
在本地测试jenkins的时候使用了docker安装,我也没有特意的选择docker的版本,直接使用yum安装,安装后jenkins的镜像也拉取下来了,在创建容器的时候出现报错“error creating overlay mount”,看下面的原文报错。
[root@wulaoer.org ~]# docker run -d --name docker-jenkins -p 8008:8080 -p 50000:50000 jenkinsci/blueocean /usr/bin/docker-current: Error response from daemon: error creating overlay mount to /var/lib/docker/overlay2/b0f3dd92ff9e3391a7ade9ad9eb9006552be07843a7e63c3f42e987b19dcb555-init/merged: invalid argument.
我一直以为是我的docker安装有问题呢,测试了好几次,在网上搜索了一下,原来是因为docker使用的是overlay2文件系统,而默认的是使用的overlay文件系统,需要更新一下文件系统。
[root@wulaoer.org ~]# systemctl stop docker [root@wulaoer.org ~]# vim /etc/sysconfig/docker-storage ..................................... DOCKER_STORAGE_OPTIONS= #改成DOCKER_STORAGE_OPTIONS="--storage-driver overlay" [root@wulaoer.org ~]# vim /etc/sysconfig/docker ............................................. OPTIONS='--selinux-enabled --log-driver=journald --signature-verification=false' 改成 OPTIONS=' --log-driver=journald --signature-verification=false' [root@wulaoer.org ~]# systemctl start docker
重启后,再重新创建即可,我这里的测试结果是可以的,如果还是不行,还是建议看看docker安装的方式,这个overlay是什么还没来得及看,以后如弄明白了,再更新一下,没有了看看其他的吧。
评论 0