👋 欢迎来到吴老二技术博客,专注运维 / 数据库 / 云原生
首页/云原生/正文

docker推送私有仓库镜像报错https

吴
吴老二
2023-10-26云原生2287 次浏览0 条评论

在私有环境里搭建的harbor仓库,因为是私有网络所以也就不用域名也就没有https,但是我在尝试往私有仓库推送镜像时发现,推送默认使用了https,这个问题是因为docker为了安全机制默认的。为了推送私有仓库总不能在使用域名后在弄个https证书吧,太麻烦了,下面看一下我的错误以及解决方法。

 Error response from daemon: Get "https://192.168.1.33/v2/": dial tcp 192.168.1.33:443: connect: connection refused

ip是我的私有仓库,我在私有仓库所在机器查看并没有443端口,哪一定是我的客户端问题,在网上找了很多方法,因为比较着急也没有细看,所以错过了很多问题。其实就是在/etc/docker/daemon.json文件中指定一下即可。

 cat /etc/docker/daemon.json
 {
   "insecure-registries": ["http://192.168.1.33"]
 }

指定使用http,然后重启一下docker即可,如果是contained可以参考:https://www.wulaoer.org/?p=2954

文章底部广告位在后台「广告设置」填写广告代码后显示

评论 0

评论需 登录 后发表(注册并验证邮箱)。
还没有评论,来抢沙发~