👋 欢迎来到吴老二技术博客,专注运维 / 数据库 / 云原生
首页/云原生/正文

kubernetes配置nodeport方式报错spec.clusterIP: Invalid value: “None”: may not be set to ‘None’ for NodePort services

吴
吴老二
2022-04-12云原生2343 次浏览0 条评论
在kubernetes中,利用nodeport方式请求,修改Deployment中的spect的clusterIP: None是集群内部访问正常,但是集群外请求需要修改成nodeport方式时报错:spec.clusterIP: Invalid value: “None”: may not be set to ‘None’ for NodePort services,如果直接在service中修改可能还不生效,但是还不能不修改。 解决方法:
apiVersion: v1
kind: Service
metadata:
  name: zookeeper
  namespace: zookeeper-system
  labels:
    app: zookeeper
spec:
  type: NodePort     #增加
  ports:
    - port: 2181
  selector:
    app: zookeeper
    tier: zookeeper
以上是个实例,把yaml文件中的clusterIP: None去掉,在spec中加type: NodePort即可
文章底部广告位在后台「广告设置」填写广告代码后显示

评论 0

评论需 登录 后发表(注册并验证邮箱)。
还没有评论,来抢沙发~