👋 欢迎来到吴老二技术博客,专注运维 / 数据库 / 云原生
首页/云原生/正文

记录一次kubesphere的报警组件异常

吴
吴老二
2024-04-10云原生2582 次浏览0 条评论

记录一次kubesphere的报警组件异常问题,今天凌晨停电了,所以所有服务都出现了重启,检查服务时发现,有两个服务一直启动失败,看了一下记录是几天之前开始出现的问题,因为是线下环境也没有特别在意就把所有服务都启动正常后,发现这两个服务还是启动不了。

 [root@k8s-master sh]# kubectl get pod -A  | grep -v Running
 NAMESPACE                      NAME                                                       READY   STATUS             RESTARTS         AGE
 kubesphere-monitoring-system   notification-manager-deployment-77d5b49896-p2jkq           1/2     CrashLoopBackOff   7 (72s ago)      12m
 kubesphere-monitoring-system   notification-manager-deployment-77d5b49896-tplnl           1/2     CrashLoopBackOff   7 (58s ago)      12m

在网上找了一下给出了思路是因为apiserver错误导致的问题,于是检查了一下apiservers看看。

 [root@k8s-master sh]# kubectl get apiservice
 ....................
 v1alpha1.o11y.prism.oam.dev            vela-system/vela-prism   False (ServiceNotFound)   13d
 v1alpha1.policy.kruise.io              Local                    True                      8h
 v1alpha1.prism.oam.dev                 vela-system/vela-prism   False (ServiceNotFound)   13d

这两个状态都是False,根据网上的建议是删除即可,因为是线下的环境也没有特别在意,直接删除操作。

 [root@k8s-master sh]# kubectl delete apiservice v1alpha1.prism.oam.dev
 apiservice.apiregistration.k8s.io "v1alpha1.prism.oam.dev" deleted
 [root@k8s-master sh]# kubectl delete apiservice v1alpha1.o11y.prism.oam.dev
 apiservice.apiregistration.k8s.io "v1alpha1.o11y.prism.oam.dev" deleted

然后再重启notification-manager-deployment组件发现既然启动成功了,这里就不展示Running状态的pod了,看些其他的吧。。。。

文章底部广告位在后台「广告设置」填写广告代码后显示

评论 0

评论需 登录 后发表(注册并验证邮箱)。
还没有评论,来抢沙发~