👋 欢迎来到吴老二技术博客,专注运维 / 数据库 / 云原生
首页/云原生/正文

rancher管理集群报错信息解决方法

吴
吴老二
2021-06-22云原生4071 次浏览0 条评论
今天在安装rancher的时候,安装好后连接阿里云的ack,总是出现错误信息如下:
Unable to connect to the server: x509: certificate is valid for 127.0.0.1, 172.17.0.2, not 10.123.6.239
最后一个地址是我本机的ip地址,我一直以为是我的网络没有到达呢?所以telnet一下apiserver的端口,测试之后没有问题,问了一下阿里云的售后反馈的是证书的问题,后来我使用的时候,确实是出现证书的错误提示。
Unable to connect to the server: x509: certificate signed by unknown authority
但是我的证书是没问题的,后来我换了一个版本,使用了比较低一点的版本,我换成了2.3.5版本的,然后在加入到集群中,就没有出现错误,问题解决。
sudo docker run -d --restart=unless-stopped -p 80:80 -p 443:443 rancher/rancher:v2.3.5
这里需要注意的是,如果使用2.3.5版本的rancher,必须使用域名访问,在域名里增加ssl证书,如果不加证书访问体验相对较差。
文章底部广告位在后台「广告设置」填写广告代码后显示

评论 0

评论需 登录 后发表(注册并验证邮箱)。
还没有评论,来抢沙发~