
云原生
利用kurise做日志采集使用promtail做sidecar采集日志
利用OpenKurise中的kruise做日志采集,原来我使用的是filebeat作为sidecar采集日志的,虽然采集没有什么问题,但是通过es进才看日志就比较繁琐了,这次实验p
Unable to connect to the server: x509: certificate is valid for 127.0.0.1, 172.17.0.2, not 10.123.6.239最后一个地址是我本机的ip地址,我一直以为是我的网络没有到达呢?所以telnet一下apiserver的端口,测试之后没有问题,问了一下阿里云的售后反馈的是证书的问题,后来我使用的时候,确实是出现证书的错误提示。
Unable to connect to the server: x509: certificate signed by unknown authority但是我的证书是没问题的,后来我换了一个版本,使用了比较低一点的版本,我换成了2.3.5版本的,然后在加入到集群中,就没有出现错误,问题解决。
sudo docker run -d --restart=unless-stopped -p 80:80 -p 443:443 rancher/rancher:v2.3.5这里需要注意的是,如果使用2.3.5版本的rancher,必须使用域名访问,在域名里增加ssl证书,如果不加证书访问体验相对较差。
评论 0