
利用nginx反向代理kubesphere终端访问
利用nginx做反向代理kubesphere,目的是为了在自建环境中通过nginx反向代理到kuberetes中的ingress,然后利用ingress做集群内部的解析,利用ngi
推荐玩了几年kubernetes,但是针对kubernetes的工具,推荐几个个人认为还算不错的工具。这里的工具主要是通过平台来管理kubernetes,方便给不太了解k8s的同学或者
推荐我们继续上一章的,点击开始后进入这个页面,会有一个欢迎视频,可以忽略点击底部的跳过,然后要求上传个人头像,这里也跳过,需要创建一个空间,这里我们创建运维部,开发部,产品部,测试部等
推荐安装gitlab时,使用rpm安装,提示错误: 这个错误提示,是因为gitlab安装时需要依赖policycoreutilspython。所以需要先安装policycoreutil
推荐kubernetes中rollout命令主要是针对资源进行管理,比如服务回滚,服务暂停,资源状态,查看历史等等。不过这里用的比较多的就是回滚版本,暂停资源,重新部署等下,下面看看在
MySQLProxySQL / dble / MHA 的选型、配置与生产踩坑记录。
12 篇 · 更新于 2026-07
Kubernetes日志采集、监控告警、RBAC、探针与调度的一线经验。
18 篇 · 更新于 2026-01
可观测性Prometheus + Grafana + Loki 从部署到告警规则。
9 篇 · 更新于 2025-12
MySQLProxySQL / dble / MHA 的选型、配置与生产踩坑记录。
12 篇 · 更新于 2026-07
Kubernetes日志采集、监控告警、RBAC、探针与调度的一线经验。
18 篇 · 更新于 2026-01
可观测性Prometheus + Grafana + Loki 从部署到告警规则。
9 篇 · 更新于 2025-12
利用nginx做反向代理kubesphere,目的是为了在自建环境中通过nginx反向代理到kuberetes中的ingress,然后利用ingress做集群内部的解析,利用ngi

简单说一下k8s的负载均衡不管是LoadBalancer还是nodeport,还是其他的等等,都是通过端口映射的方式进行数据请求的,主要原因是因为在kubernetes中,ipvs

ingress的主要目的是为了控制用户请求pod的一个入口,当然了,如果使用nodeport的方式更简单点,但是我需要给很多个服务设置端口,这种请求方式不太能接受,而且如果我使用n

在kubernetes集群中部署jenkins集群,前面安装kubernetes的时候为了省劲就在原有的swarm的基础上直接部署了,结果各种问题,所以也都一一解决了,但是在安装j

kubernetes安装好后,因为代理的问题所以就没有安装什么服务,有的安装好后也就没有测试,后来发现安装后在jenkins的时候安装不上,我一直以为是我的版本的问题,后来看日志,

今天在安装kubernetes的时候,什么都安装好了,但是在安装jenkins的时候提示一直安装不上去,后来发现原来pod中无法域名解析,主要原因是因为我的系统内核版本太低了,这里

原来的环境部署的是swarm集群,但是偷懒就没有把集群中的服务删除,直接安装了kubernetes,导致安装之后出现各种问题,安装成功之后只有一个节点的calico启动不了,显示的

在swarm集群中部署的微服务集群,原本测试的时候使用的是网上找的测试用例,因为也没有深入的测试,所以认为网络可以,但是换成自己的服务时,发现集群中有些服务可以有些服务不可以,因为