
swarm集群服务之间通信
了解swarm的应该都知道swarm是kubernetes的早期版本,所以这里不在描述,在swarm中也是一样,在集群内部同一个网络中的服务通信是可以直接通过服务名称加端口的方式直
推荐玩了几年kubernetes,但是针对kubernetes的工具,推荐几个个人认为还算不错的工具。这里的工具主要是通过平台来管理kubernetes,方便给不太了解k8s的同学或者
推荐我们继续上一章的,点击开始后进入这个页面,会有一个欢迎视频,可以忽略点击底部的跳过,然后要求上传个人头像,这里也跳过,需要创建一个空间,这里我们创建运维部,开发部,产品部,测试部等
推荐安装gitlab时,使用rpm安装,提示错误: 这个错误提示,是因为gitlab安装时需要依赖policycoreutilspython。所以需要先安装policycoreutil
推荐kubernetes中rollout命令主要是针对资源进行管理,比如服务回滚,服务暂停,资源状态,查看历史等等。不过这里用的比较多的就是回滚版本,暂停资源,重新部署等下,下面看看在
MySQLProxySQL / dble / MHA 的选型、配置与生产踩坑记录。
12 篇 · 更新于 2026-07
Kubernetes日志采集、监控告警、RBAC、探针与调度的一线经验。
18 篇 · 更新于 2026-01
可观测性Prometheus + Grafana + Loki 从部署到告警规则。
9 篇 · 更新于 2025-12
MySQLProxySQL / dble / MHA 的选型、配置与生产踩坑记录。
12 篇 · 更新于 2026-07
Kubernetes日志采集、监控告警、RBAC、探针与调度的一线经验。
18 篇 · 更新于 2026-01
可观测性Prometheus + Grafana + Loki 从部署到告警规则。
9 篇 · 更新于 2025-12
了解swarm的应该都知道swarm是kubernetes的早期版本,所以这里不在描述,在swarm中也是一样,在集群内部同一个网络中的服务通信是可以直接通过服务名称加端口的方式直

swarm的资源限制和kubernetes的资源限制一样,分别使用reserve和limit对容器资源进行限制,也可以理解为最大最小,而reserve可以理解为最小范围,初始资源大

今天在部署ELK的时候,服务都安装好了,准备进行验证的时候,发现验证不了。在本地通过ip+端口的方式也不能请求,也不提示错误,就是请求不了,后来看了一下端口,发现端口都在TCP6上

最小化安装的centos8,安装的时候选择的语言是中文,但是安装好后,登录的时候提示"bash: warning: setlocale: LC\ALL: cannot change

docker安装好后,发现启动的时候报错,这里详细分析一下docker启动错误的方法。首先是启动docker,提示错误让你查看启动错误的日志,但是日志内容比较少,又没有详细的错误内

安装新版本docker的时候,发现启动不起来,因为以前使用这个镜像的时候直接启动了,也没有遇到过。也就谷歌了一下,发现是配置问题,因为以前没有遇到过,这里就记录一下, 虽然我是yu

最近在整合环境,前面基础环境都整合好了,就差jenkins了,原本想着使用docker安装的,但是最近使用docker安装插件的时候国内的443端口有问题,导致插件一直安装失败,早

我们一般在创建容器的时候,都是使用的普通用户进入容器,但是使用普通用户进入容器后就会出现有一些文件没有权限查看,很有就是安装等等很是麻烦,这里就说一下如何通过root用户进入容器,