👋 欢迎来到吴老二技术博客,专注运维 / 数据库 / 云原生

专题精选

更多专题 →

最新文章

运维服务

如何使用 NGINX 限制上传文件类型

在 Web 应用程序中,限制用户上传的文件类型是确保安全性和合规性的重要步骤之一。NGINX 是一个流行的 Web 服务器,可以通过配置来限制上传文件的类型。本文将介绍如何使用 N

2024-03-104096 次浏览0 条评论
运维服务

nginx安全优化限制版本号

在使用nginx的过程中,出现403错误时,会提示403 Forbidden错误,这个错误出现的同时还会出现nginx的版本号,这时我们为了防止中间件被攻击,就需要在nginx提示

2024-03-092463 次浏览0 条评论
云原生

kubernetes高可用集群证书升级

kubernetes默认安装成功后其中api,etcd,scheduler,controllermanager四个组件的证书是有效期是一年,等组件证书到期后就无法直接创建服务,更新

2024-03-081827 次浏览0 条评论
云原生

高可用集群etcd集群节点启动失败

今天在玩自己的k8s集群是,突然有一个master节点上的etcd和api无法启动,不管如何删除重新创建还是现实启动失败。 查看日志显示是因为etcd数据损坏了,导致数据不一致,所

2024-03-071967 次浏览0 条评论
编程开发

切片copy

当我们需要在Go语言中复制一个切片时,我们可以使用内置的copy函数。copy函数可以将一个切片的元素复制到另一个切片中。下面是一个示例: 在上面的示例中,我们首先创建了一个源切片

2024-01-161971 次浏览0 条评论
云原生

kubernetes中配置一个本地解析

有些时候为了安全考虑,针对服务内部直接调用第三方信息不允许使用解析的域名,需要本地解析,如果本地解析把解析配置在node节点有点麻烦了,而且也不一定能够使用宿主机的解析,所以考虑是

2024-01-151855 次浏览0 条评论
云原生

kubernetes中部署ES集群

在kubernetes中部署Elasticsearch集群需要用到数据持久化,这里可以使用ntfs也可以使用openebs做数据持久化,两者皆可,如果使用ntfs可以参考:http

2024-01-112244 次浏览0 条评论
云原生

hostNetwork实现pod和宿主机的通信

首先,我们需要理解一下\hostNetwork: true\ 是 Kubernetes 中一个用于 Pod 配置的选项,它允许 Pod 直接使用主机的网络命名空间。当你将 \hos

2024-01-102348 次浏览0 条评论