
kubernetes配置nodeport方式报错spec.clusterIP: Invalid value: “None”: may not be set to ‘None’ for NodePort services
在kubernetes中,利用nodeport方式请求,修改Deployment中的spect的clusterIP: None是集群内部访问正常,但是集群外请求需要修改成nodep
推荐玩了几年kubernetes,但是针对kubernetes的工具,推荐几个个人认为还算不错的工具。这里的工具主要是通过平台来管理kubernetes,方便给不太了解k8s的同学或者
推荐我们继续上一章的,点击开始后进入这个页面,会有一个欢迎视频,可以忽略点击底部的跳过,然后要求上传个人头像,这里也跳过,需要创建一个空间,这里我们创建运维部,开发部,产品部,测试部等
推荐安装gitlab时,使用rpm安装,提示错误: 这个错误提示,是因为gitlab安装时需要依赖policycoreutilspython。所以需要先安装policycoreutil
推荐kubernetes中rollout命令主要是针对资源进行管理,比如服务回滚,服务暂停,资源状态,查看历史等等。不过这里用的比较多的就是回滚版本,暂停资源,重新部署等下,下面看看在
MySQLProxySQL / dble / MHA 的选型、配置与生产踩坑记录。
12 篇 · 更新于 2026-07
Kubernetes日志采集、监控告警、RBAC、探针与调度的一线经验。
18 篇 · 更新于 2026-01
可观测性Prometheus + Grafana + Loki 从部署到告警规则。
9 篇 · 更新于 2025-12
MySQLProxySQL / dble / MHA 的选型、配置与生产踩坑记录。
12 篇 · 更新于 2026-07
Kubernetes日志采集、监控告警、RBAC、探针与调度的一线经验。
18 篇 · 更新于 2026-01
可观测性Prometheus + Grafana + Loki 从部署到告警规则。
9 篇 · 更新于 2025-12
在kubernetes中,利用nodeport方式请求,修改Deployment中的spect的clusterIP: None是集群内部访问正常,但是集群外请求需要修改成nodep

因为需求在kubernetes上部署zookeeper,但是zookeeper是有状态的服务,所以我在集群中已经部署了ceph,如有兴趣可以参考:https://www.wulao

好久没有做核酸检测了,导致健康宝出现异常。以前没觉得有什么,自从健康宝出现异常后,买东西都不方便了,看见人群自觉的躲避一下。恐怕因为自己的异常,或者说万一自己感染传染到别人,总觉得

以前不知道谁搞的gitlab搭建好之后即然做了对外的端口映射,导致没两天都会有一些dos攻击,或者是挖矿的在gitlab服务中运行,导致cpu飙高,每次清理后,不超过一天还会继续有

灰度的方式有很多中,这里介绍在kubernetes中ingress根据head头做灰度,灰度的目的是为了在上线之前指定一部分用户可以访问,针对整个业务流程访问都没有问题之后在发布到

无意中测试功能的时候发现配置错误导致请求一次就会创建一个pod,后来写了一个脚本导致创建了一千多个pod,但是这些pod又是没有用的,删除是个麻烦事,如果一个一个的删除太麻烦了,批

ceph是一个分布式存储系统,在现有的互联网中很多存储都是给予ceph做的,不过这里不说直接安装ceph,在linux环境中直接安装ceph很简单,网上也有很多说明,但是对于cep

本章主要是针对跨库查表的内容,这里会创建两个库分别是team和test,在这两个库中创建了两个表,分别是student和wulaoer两个表,表中已经插入了数据。可以参考:http