
kubernetes环境中部署rocketmq多主多从集群
rocketmq的多主多从的优势这里就不多说了,在kubernetes中部署rocketmq的有点就是负载自动启动。这里使用两主两从,如果需要增加只需要负载一份主从即可,看一下ya
共 180 篇文章

rocketmq的多主多从的优势这里就不多说了,在kubernetes中部署rocketmq的有点就是负载自动启动。这里使用两主两从,如果需要增加只需要负载一份主从即可,看一下ya

前几天刚升级了kubernetes,今天突然发现,在k8s中有个别的服务不可用,通过日志排除发现,原来请求的负载均衡的地址变化了,这个在coredns中没有自动的更新。但是在cor

闲来无事,就做一下版本升级的记录,前面做过单节点master升级集群高可用的案例,这里的升级也是在高可用集群的基础上实现的,所以这里我就不备份etcd了,如果是单节点集群一定要备份

记录一次kubesphere的报警组件异常问题,今天凌晨停电了,所以所有服务都出现了重启,检查服务时发现,有两个服务一直启动失败,看了一下记录是几天之前开始出现的问题,因为是线下环

在kubernetes中,运行一段时间后,会发现有一些容器在重启后正常会自动删除Terminating状态的pod,但是有时候有些的pod一直没有自动删除掉,如果是异常的pod不删

Docker Compose简介 Docker Compose是一个用于定义和运行多容器Docker应用程序的工具。通过一个单独的文件,您可以配置应用程序的服务、网络和卷,然后使用

原本都是把rocketmq都放在集群内部使用的,这样也不担心权限问题,前几天有个需求要求把rocketmq允许集群外部的服务调用,但是还要求必须进行权限控制。翻阅了很多,都是在do

kubernetes默认安装成功后其中api,etcd,scheduler,controllermanager四个组件的证书是有效期是一年,等组件证书到期后就无法直接创建服务,更新

今天在玩自己的k8s集群是,突然有一个master节点上的etcd和api无法启动,不管如何删除重新创建还是现实启动失败。 查看日志显示是因为etcd数据损坏了,导致数据不一致,所

有些时候为了安全考虑,针对服务内部直接调用第三方信息不允许使用解析的域名,需要本地解析,如果本地解析把解析配置在node节点有点麻烦了,而且也不一定能够使用宿主机的解析,所以考虑是